Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 165 / Bezoekers Vandaag: 6485
Hoogste aantal aktieve gebruikers: 496
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

Op 18 Maart 2019 is Paul Haagsma helaas overleden.

Wij wensen de familie en vrienden sterkte toe!

Lees en of praat hier mee.

Open hier de rouwkaart van Paul Haagsma



 Alle forums
 Installatie
 Technische installatie
 Geen communicatie koploper>Ecos
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Volgende pagina
Auteur Vorig onderwerp Onderwerp Volgend onderwerp Pagina: 1 2 (of 2)

johanerik

Netherlands
9 berichten

Geplaatst - 08 mrt 2009 :  16:38:34  Toon profiel  Reageer met citaat
Ik heb een nieuwe laptop met Vista besturing. Via de Internetbrowser kan prima worden gecommuniceerd met de Ecoscentrale voor het b.v. een backup maken van de Ecos-instellingen. In koploper is het juiste IP adres ingevuld alsmede het poortnummer. Bij het verbinding maken krijg ik steeds de melding: "Er is geen communicatie met het digitale systeem". Ik word er al een week gek van! Wie kent dit probleem of nog beter: wie heeft de oplossing.

Han Goudswaard

Bewerkt door johanerik op 08 mrt 2009 19:34:28

Wissels

Netherlands
1435 Posts

Geplaatst - 08 mrt 2009 :  16:53:24  Toon profiel  Bezoek de homepagina van Wissels  Reageer met citaat
Hallo Han,

Als je de Vista (be)storing nu allereerst vervangt door besturing. Sorry kon het niet laten.

als je via de browser contact hebt, dan moet dat met koploper ook lukken, sluit wel je internetbrowser af, want je mag slechts met 1 programma tegelijk contact maken met je Ecos. Aan de poort zou je niks in hoeven te stellen want deze staat standaard al goed op 15471.

Let wel bij een nieuwe start van je Ecos kan het Ip adres gewijzigd zijn want deze wordt automatisch door je Router toegewezen.

met vriendelijke groet,

Walter



Marklin testbaan met 6021/6050 Vaste baan met Central Station 1
Ga naar bovenaan de pagina

dikken

Belgium
39 Posts

Geplaatst - 08 mrt 2009 :  18:17:53  Toon profiel  Bezoek de homepagina van dikken  Reageer met citaat
Hallo Han,

Je kan je Ecos ook een vast ip adres geven (binnen de range vanje netwerk)en DHCP uitschakelen. zo werk je steeds met het zelfse ip adres en moet je niet steeds gaan zoeken.

kijk ook eens naar de "instellingen per database" of het prrotnummer wel degelijk op aansturen staat en niet op testen.



greetz, Bart

Bewerkt door dikken op 08 mrt 2009 18:18:19
Ga naar bovenaan de pagina

johanerik

Netherlands
9 Posts

Geplaatst - 08 mrt 2009 :  20:01:27  Toon profiel  Reageer met citaat
Hallo Bart en Walter,

Bedankt voor jullie reacties. Ik werk al met een vast IP-adres, DHCP staat uit. De verbinding geschiedt door een datakabel. IP-adressen kloppen, poortnummer klopt, staat op "aansturen". Bij verder zoeken bij initialisaties geeft koploper bij het indrukken van de knop "communicatiepoort sluiten" de reactie "poort is al gesloten". Waaraan ik de conclusie verbind dat bij het opstarten van koploper de poort om zo te zeggeb niet opengaat! Weten jullie wat de functie is van "gateway" bij de Ecos netwerkinstellingen?

Goeten, Han.
Ga naar bovenaan de pagina

Wissels

Netherlands
1435 Posts

Geplaatst - 08 mrt 2009 :  20:58:24  Toon profiel  Bezoek de homepagina van Wissels  Reageer met citaat
Hallo Han,

voorbeeld instelling voor een vast ip adres, in een homenetwerk

Ip adres 192.168.1.2 het laatste cijfer mag ingevuld worden van 1-256 en mag slechts 1 maal in een netwerk voorkomen, dit is tevens het adres die in koploper ingevuld moet worden, met ditzelfde adres is de Ecos ook via explorer oproepbaar. Uiteraard wel je Explorer verbinding uitschakelen voordat je met Koploper verbinding probeert te maken.

Gateway hoeft niet ingevuld te worden, deze mag in alle velden op 0 blijven staan.

Netmask 255.255.255.0

met vriendelijke groet,

Walter

Marklin testbaan met 6021/6050 Vaste baan met Central Station 1
Ga naar bovenaan de pagina

PaHaSOFT

3413 Posts

Geplaatst - 08 mrt 2009 :  21:10:35  Toon profiel  Reageer met citaat
Han/Walter,

Ik ben zelf wel overtuigd dat het IP-adres goed wordt ingegeven. Het vreemde in dit verhaal: het lukt wel via de internetbrowser om verbinding te maken met de Ecos en via Koploper lukt het niet.

@Han
Als jij hebt probeert in Koploper is de internetbrowser dan nog geactiveerd?

Mvg,
Paul.
Ga naar bovenaan de pagina

johanerik

Netherlands
9 Posts

Geplaatst - 08 mrt 2009 :  21:29:06  Toon profiel  Reageer met citaat
Aan alle helpers,

Ik start de computer, vanaf het bureaublad start ik koploper, dus de internetbrowser is op dat moment nog niet actief geweest en staat dus naar mijn mening niet aan.

Han.
Ga naar bovenaan de pagina

Agebe

Netherlands
402 Posts

Geplaatst - 08 mrt 2009 :  21:51:31  Toon profiel  Reageer met citaat
Hallo Han,

In het begin vertel je dat er met Vista wordt gewerkt.
De internet browser is een vetrouwde omgeving voor Vista.
Probeer eens even om de Firewall uit te zetten, en kijk eens of het dan wel lukt.
Als het dan wel gaat moeten er wat uitzonderingen in de firewall gezet worden.
Opm. De communicatie poort blijft altijd gesloten, met de Ecos doet deze niet mee.
De Ecos werkt met een netwerk aansluiting.
Zelf heb ik wel eens de internet browser en koploper aan (XP) Geeft geen problemen.
Maar voor de zekerheid gebruik een van beide te gelijk.

Mvg Ab Boezerooij

Ab Boezerooij (Koploper,ECOS-IB,HSI-88, HO, NS)
Ga naar bovenaan de pagina

johanerik

Netherlands
9 Posts

Geplaatst - 09 mrt 2009 :  14:26:27  Toon profiel  Reageer met citaat
Hallo Ab,

Bedankt voor de reactie. De Vista firewall blijkt uit te staan. Voor de zekerheid heb ik de Norton persoonlijke firewall en een aantal andere Norton instellingen ook uitgezet. Helaas zonder resultaat.

Han.
Ga naar bovenaan de pagina

Wissels

Netherlands
1435 Posts

Geplaatst - 09 mrt 2009 :  18:13:03  Toon profiel  Bezoek de homepagina van Wissels  Reageer met citaat
Hallo Han,

Met de Norton firewall had ik geen enkel problemen om verbinding te krijgen met het Marklin Central Station 1, waarmee je op dezelfde manier en met dezelfde poort verbinding moet maken met de Ecos.

Vreemd blijft dat je wel iedere keer opnieuw ??? zonder problemen met de browser contact krijgt met de Ecos, en daarna met hetzelfde Ip adres vanuit Koploper niet ??????

Controleer ook of het lampje op de Ecos van de netwerk verbinding reageert op het moment dat koploper verbinding probeert te maken.

Zou jij een screenshot kunnen plaatsen van de Koploper instellingen om met de Ecos verbinding te kunnen maken,

met vriendelijke groet,

Walter



Marklin testbaan met 6021/6050 Vaste baan met Central Station 1
Ga naar bovenaan de pagina

efl045

Belgium
18 Posts

Geplaatst - 09 mrt 2009 :  23:03:15  Toon profiel  Reageer met citaat
Hallo Han,

Is Windows Defender sosm actief op je PC? Indien wel, dan moet je het Koploper onderdeel "zlportio.sys" wel toelaten om uitgevoerd te worden, Defender kent dat niet en belet dus de communicatie:

Download Attachment: defender.jpg
84,64 KB

Groeten,

Franky
Ga naar bovenaan de pagina

efl045

Belgium
18 Posts

Geplaatst - 10 mrt 2009 :  00:05:09  Toon profiel  Reageer met citaat
Hallo Han,

Ik gebruik XP en heb bewust Windows Defender op mijn PC gezet en geactiveerd, maar 'k heb ondertussen gezien dat Defender onder Vista standaard is geïntegreerd.
't Zit er dus dik in dat dit de oorzaak is.
Hier vind je er meer over: http://www.minatica.be/tutorials.php?do=file&id=93

Groeten,

Franky
Ga naar bovenaan de pagina

PaHaSOFT

3413 Posts

Geplaatst - 10 mrt 2009 :  07:49:23  Toon profiel  Reageer met citaat
Franky/Han,

Ik zeg nooit nooit, maar het lijkt mij sterk dat dit de oorzaak is. Veel en veel meer gebruikers zouden hiervan last moeten hebben. zlportio.sys wordt gebruikt om te communiceren naar de parallelle poort en meer niet. Het netwerk staat hier dus volledig buiten.

Tenzij natuurlijk Han een item van de parallel63 heeft aangemaakt en wil gebruiken....

Mvg,
Paul.
Ga naar bovenaan de pagina

Agebe

Netherlands
402 Posts

Geplaatst - 10 mrt 2009 :  09:09:20  Toon profiel  Reageer met citaat
Hallo Allemaal,

"zlportio.sys" Geeft geen problemen in de communicatie met koploper en randapparatuur.
Alleen geeft Windefender een waarschuwing in het overzicht.
Gebruik hier ook geen parallelle poort!!
Normaal gebruik ik windows XP, maar ooit heb ik de Ecos met de huiskamer- computer (Vista) verbinding laten maken. En dat lukte. Hiertoe diende ik wel de comm voor de HSI-88 uit te schakelen.

Er zijn echter wel een aantal vorwaarden om tot een verbinding te komen met de Ecos.
Iets om over na te denken!!

Bij een rechtstreekse verbinding tussne PC en Ecos gebruik een Cross patch kabel.
Zet eerst de PC aan en daarna de Ecos. De Ecos wil nl een spanning op de UTP aansluiting zien. Anders is er geen communicatie mogelijk.

Wordt de Ecos via een router met de PC verbonden, zorg dan dat de IP range die de router aan diverse PC's toekent buiten het IP nummer van de Ecos ligt. Voorbeeld router: 192.168.100 t/m 108. De Ecos mag dan op 192.168.109 gezet worden.
Dit om te voorkomen dat een PC in een netwerk een adres krijgt waar de Ecos op staat, dan gaat de communicatie ook niet goed. Geldt ook voor het draadloze netwerk, zorg gewoon dat er geen dubbele IP adreesen voorkomen.

Tenslotte is er ook nog een switch, daar valt weinig aan in te stellen, maar hier geldt ook eerst de switch aan en als laatste de Ecos. (Bij mij staat de switch altijd aan.)

Bij gebruik van een router of switch kan een gewone patch kabel worden gebruikt.
(Patch kabel is UTP kabel met RJ45 connectoren.)Geen Cross

In het explorer window is te zien welke IP adressen, gateway e.d. gebruikt worden.
Kijk of dit ook overeen komt met het IP adres in koploper.

Han: kan je hier iets uit filteren wat van toepassing is.

Allen: Als er nog iets is wat ik ben vergeten graag aanvullen.

Mvg Ab Boezerooij




Ab Boezerooij (Koploper,ECOS-IB,HSI-88, HO, NS)
Ga naar bovenaan de pagina

PaHaSOFT

3413 Posts

Geplaatst - 10 mrt 2009 :  09:12:45  Toon profiel  Reageer met citaat
Ab,

Maar het vreemde in het hele verhaal is dat Han wel vanuit zijn browser contact kan maken met de Ecos en niet vanuit Koploper.

Mvg,
Paul.
Ga naar bovenaan de pagina

efl045

Belgium
18 Posts

Geplaatst - 10 mrt 2009 :  09:40:55  Toon profiel  Reageer met citaat
Dag Ab,

In heel jouw verhaal zie ik niets dat ook niet zou beletten om via een browser contact te krijgen met de Ecos. En via de browser lukt het wel. Dus dat kan allemaal de oorzaak niet zijn.
Het moet iets zijn dat enkel met Koploper te maken heeft, vandaar dat ik uit kwam bij de parallel driver. Ik kan dat zelf niet testen, er hangt bij mij dan ook niks aan de parallelpoort, maar ik merk wel als ik een decoder63 definiëer die er niet is, dat Koploper dit eerst ziet en dan niet meer verder doet en ook geen communicatie opbouwt met de CS/ECOS. Er komt dan wel een foutmelding dat de parallel63 er niet is. Maar ik vroeg mij af wat er gebeurt als de zlportio.sys niet kan uitgevoerd worden. Ik ben er vrij zeker van dat dan ook geen communicatie zal opgebouwd worden met de CS/ECOS, maar of er dan ook een foutmelding komt kan enkel Paul weten.

Groeten,

Franky
Ga naar bovenaan de pagina

PaHaSOFT

3413 Posts

Geplaatst - 10 mrt 2009 :  10:43:53  Toon profiel  Reageer met citaat
Franky,

Ik schreef toch al dat er met parallelle poort wordt gecommuniceerd als er in onderhouden digitale onderdelen een parallel63 is gedefinieerd. Anders doe ik er echt niets mee en heeft het totaal geen belemmering voor het netwerk verkeer.

Mvg,
Paul.
Ga naar bovenaan de pagina

efl045

Belgium
18 Posts

Geplaatst - 10 mrt 2009 :  10:57:44  Toon profiel  Reageer met citaat
Dag Wim,

Ja, dat had je natuurlijk al geschreven, maar ik reageerde eigenlijk op Ab. Ik begreep uit zijn reactie dat hij wilde zeggen dat de paralleldriver niet kan beletten dat er netwerkcommunicatie is, maar ik had gemerkt dat als er iets is met de paralleldriver, Koploper niet eens toe komt aan netwerkcommunicatie. Of met andere woorden dat met het netwerk alles voor 100% in orde kan zijn en er toch niet over gecommuniceerd wordt omdat Koploper zover niet komt. 't Is gewoon de volgorde van wat eerst gebeurt.
Maar in tekst is dat allemaal een beetje moeilijker uit te leggen dan verbaal, sorry als je mijn reactie overbodig vond, maar ik probeer enkel duidelijk te zijn. En mee te zoeken naar het probleem, want als ik het goed voor heb is dat er toch nog altijd, en waar kan het dan wel nog aan liggen? De mogelijkheden geraken wel uitgeput zou ik zo denken...

Groeten,

Franky
Ga naar bovenaan de pagina

Agebe

Netherlands
402 Posts

Geplaatst - 10 mrt 2009 :  12:26:55  Toon profiel  Reageer met citaat
Hallo Allemaal,

Het antwoord was een algemeen iets waarmee misschien iets gefilterd kan worden wat er loos is.
Kan vanavond pas kijken of ik iets na kan spelen.

Mvg Ab Boezerooij

Ab Boezerooij (Koploper,ECOS-IB,HSI-88, HO, NS)

Bewerkt door Agebe op 10 mrt 2009 16:28:41
Ga naar bovenaan de pagina

johanerik

Netherlands
9 Posts

Geplaatst - 10 mrt 2009 :  19:42:31  Toon profiel  Reageer met citaat
Aan alle helpers,
Bedankt allemaal, jullie meedenken doet mij goed. Voor alle duidelijkheid: De verbinding tussen mijn PC en de Ecos is een LAN-netwerk via een patchkabel; er is dus geen router actief. Ik heb de instellingen (netwerk, koploper, browser en ecos) via printscreens in een PDF-bestand gezet. Volgens mij staat alles goed maar misschien zie ik iets over het hoofd.

Han.

Download Attachment: IP_details.pdf
149,5 KB
Ga naar bovenaan de pagina

Agebe

Netherlands
402 Posts

Geplaatst - 10 mrt 2009 :  22:31:25  Toon profiel  Reageer met citaat
Hallo Han,

Zo te zien staat alles goed.
Heb het helaas niet kunnen na spelen.
Het enige waar ik wel verbinding met explorer kreeg en niet met koploper was als ik het Poortnumeer wijzigde.
Maar zo te zien staat dat ook goed.

Alleen staan bij mijn computers de internet protocol versie op automatisch ,alsmede de de DNS server staan op automatisch.

Over de netwerkkabel heb ik mijn twijfels als het rechtstreeks (peer to Peer) zou dat een Cross kabel moeten zijn.
Maar als dit verkeerd zou zijn heb je op geen enkele manier verbinding.
Ik heb een blokje waarmee ik een cross verbinding kan maken, dus voor mijn systeem verkeerd, dan werkt er geen van beide.
Misschien toch eens een cross kabel gebruiken, om te kijken wat er dan gebeurd.

Mvg Ab Boezerooij

Ab Boezerooij (Koploper,ECOS-IB,HSI-88, HO, NS)
Ga naar bovenaan de pagina

Wissels

Netherlands
1435 Posts

Geplaatst - 10 mrt 2009 :  22:38:15  Toon profiel  Bezoek de homepagina van Wissels  Reageer met citaat
Hallo Han,

ik sluit mij helemaal bij Ab aan, een crosswired Lan cable kan naar mijn mening het probleem oplossen, aan de instellingen is niks vreemds te ontdekken, ip adressen en poort staan goed ingesteld,

Mocht je al een netwerkkabel voor je computer bij de treinbaan hebben liggen, dan is een (2e) router aan te bevelen, waar zowel de computer als de Ecos op aangesloten worden.

met vriendelijke groet,

Walter



Marklin testbaan met 6021/6050 Vaste baan met Central Station 1
Ga naar bovenaan de pagina

rdhaan

Netherlands
22 Posts

Geplaatst - 10 mrt 2009 :  22:38:49  Toon profiel  Reageer met citaat
Hallo alleen,

Ik zag in de screenshots dat de ECOS nog op 1.0.1 draait.
Als ik het goed herinner moet er minimaal 1.1.0 op staan wil de communicatie goed lopen via de netwerk interface (en dit staat dan los van de 'web' interface).

Probeer eerst de ECOS n's te updaten naar de huidige 1.1.3

Rene.
Ga naar bovenaan de pagina

Agebe

Netherlands
402 Posts

Geplaatst - 10 mrt 2009 :  23:08:58  Toon profiel  Reageer met citaat
Hallo Rene,

Daar heb je inderdaad een punt, en je leest daar heel makelijk overheen.
Aan een update zitten inderdaad een heleboel voordelen.


Mvg Ab Boezerooij

Ab Boezerooij (Koploper,ECOS-IB,HSI-88, HO, NS)
Ga naar bovenaan de pagina

Agebe

Netherlands
402 Posts

Geplaatst - 11 mrt 2009 :  09:16:23  Toon profiel  Reageer met citaat
Han,

Om te updaten raad ik je aan om eerst eens op het forum van ESU te kijken.
www.esu.eu of http://www.esu.eu/forum/ , daar vind je informatie over de update en waar je deze kan downloaden. Ook lees je daar van welke versie naar welke versie je kan updaten. Soms is het niet mogelijk om direct naar de laatste versie te gaan.
En dien je meerdere updates uit te voeren.

Om het forum te bereiken dien je eerst te registreren.
Als je niet zeker bent om zelf te updaten kan je het ook aan je handelaar vragen.

Mvg Ab Boezerooij

p.s. Het forum is Duits en Engels.

Ab Boezerooij (Koploper,ECOS-IB,HSI-88, HO, NS)

Bewerkt door Agebe op 11 mrt 2009 14:51:08
Ga naar bovenaan de pagina

johanerik

Netherlands
9 Posts

Geplaatst - 11 mrt 2009 :  15:37:13  Toon profiel  Reageer met citaat
Ab en Rene,

Ik ben al geregisteerd bij ESU. De downloads staan al in mijn PC. Volgens de instructies moet versie 1.0.1 in één keer kunnen worden geupdate naar 1.1.3. Voor de zekerheid heb ik deze vraag nog maar even op het ESU-forum gezet.

Han Goudswaard
Ga naar bovenaan de pagina
Pagina: 1 2 (of 2) Vorig onderwerp Onderwerp Volgend onderwerp  
Volgende pagina
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina