Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 198 / Bezoekers Vandaag: 1964
Hoogste aantal aktieve gebruikers: 397
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

 Alle forums
 Update's
 Versie 7.4
 Handregelaars in 7.4
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp Volgend onderwerp  

AntonBuiteweg

Belgium
18 berichten

Geplaatst - 04 jan 2012 :  15:42:26  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Zojuist een upgrade gedaan van 7.2 naar 7.4. Helaas geconstateerd dat de handregelaars op de gamepoort onder XP niet meer werken. Met versie 7.2 werkten zij nog wel.
Is hiervoor een oplossing anders dan terugaan naar 7.2.
Kan ik eventueel de database terugzetten naar versie 7.2.

MVG

Anton Buiteweg

Wim Ros

Netherlands
5308 Posts

Geplaatst - 04 jan 2012 :  18:33:33  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Anton,

Als jij van de database oude versie (7.2) een backup hebt gemaakt kun je terug anders is het helaas pindakaas.

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus

Bewerkt door Wim Ros op 04 jan 2012 18:34:10
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 04 jan 2012 :  20:32:47  Toon profiel  Reageer met citaat
Anton,

Source zitten vergelijken en ik kom wat betreft deze aansturing inzake de gameport geen verschillen tegen tussen versie 7.2 en 7.4. Of het heeft ook onder versie 7.2 niet goed gewerkt of dat was op een andere Pc waar niet Windows XP op draait.

Als jij echt overtuigt bent dat het met versie 7.2 op die Xp machine wel heeft gewerkt mag je langskomen met de Pc en handregelaar dan wil ik hier best eens kijken of ik het probleem voor je kan oplossen. Voor langskomen neem dan even verder prive contact met mij op.
Ga naar bovenaan de pagina

AntonBuiteweg

Belgium
18 Posts

Geplaatst - 12 jan 2012 :  11:25:17  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Bedankt voor jullie reactie Wim en Paul. Ik had ergens iets gelezen over het niet (meer) werken van regelaars op de game poort onder XP en heb toen bij mijzelf gecontroleerd. De regelaar werkte onder 7.2. Ik zal nu 7.2 terugzetten en een nieuwe database maken (helaas heb ik geen back-up gemaakt van de database onder versie 7.2). Zodra ik constateer dat de regelaar werkt neem ik contact op Paul en in het andere geval zal ik je zeker ook berichten. Gezien andere werkzaamheden kan dat wel even duren.
mvg
Anton Buiteweg
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 12 jan 2012 :  12:54:39  Toon profiel  Reageer met citaat
Anton,

Het enige wat er volgens mij is bijgekomen is een dat als het starten van de joystickdrivers niet lukt de gebruiker hiervan een melding krijgt (en niet alleen in de logging).

Mvg,
Paul.
Ga naar bovenaan de pagina

AntonBuiteweg

Belgium
18 Posts

Geplaatst - 13 jan 2012 :  13:51:26  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Hallo Paul,
Ik kreeg inderdaad de melding dat onder XP deze regelaars niet werken (onder 7.4). Even wat tijd stelen:
Ik heb inmiddels 7.2.0.0 terug gezet en een testdatabase gemaakt. De regelaar doet het nu weer. Verder gebruik ik Mrdirect op een tweede PC (maar dat zal wel niets uitmaken) en als regelaar een "echte" joystick. Dit laatste om eerst even te testen.
Toen toch maar weer 7.4 build 4 geinstalleerd en nu werkt de regelaar ineens weer wel. De raadselen van Bill? Ik krijg ook geen melding meer. Mijn probleem is dus opgelost??
Ter info: ik gebruik windows XP home edition versie 5.1 service pack 2. (Build 2600.xpsp_sp2_rtm.040803-2158). Aangezien de PC niet in een netwerk hangt doe ik geen windows updates meer. Mocht je meer info willen dan hoor ik dat wel. Rest mij je te danken voor je tijd en tot slot: je hebt een geweldig product gemaakt!
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 13 jan 2012 :  14:15:08  Toon profiel  Reageer met citaat
Hallo Anton,

In Windows heb ik ook niet altijd grip met Koploper wat er precies gebeurd. Blij voor je dat het lijkt te werken.

Mvg,
Paul.
Ga naar bovenaan de pagina

AntonBuiteweg

Belgium
18 Posts

Geplaatst - 13 jan 2012 :  14:17:11  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Paul,
Ik heb toch nog een "oorzaak" gevonden. Als je na het opstarten van koploper onderhoud aan een blok doet en deze wijziging al dan niet wegschrijft werkt de regelaar daarna niet meer. Het opnieuw opstarten van koploper verhelpt het probleem. Mogelijk heb je hier iets aan en overigens is hier goed mee te leven!

mvg
Anton
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 13 jan 2012 :  16:33:49  Toon profiel  Reageer met citaat
Anton,

Wat gebeurt er als je na starten van Koploper op de F5 toets drukt (start communicatie). Als ik jouw verhaal lees werkt het nu.
Als je nu via de F5 de communicatie weer uitzet en hierna nogmaals met F5 weer aan, werkt het dan nog steedsof is het eine oefening?

Ik ben nieuwsgierig of het ook zonder de tussenstap van onderhoud blokken fout gaat?

Mvg,
Paul.
Ga naar bovenaan de pagina

AntonBuiteweg

Belgium
18 Posts

Geplaatst - 14 jan 2012 :  09:28:44  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Hallo Paul,
Na het opstarten van koploper werkt de regelaar pas nadat ik de groen plak bedien (start communicatie). Dit lijkt mij correct. Opnieuw stoppen communicatie en weer starten zorgt ervoor dat de regelaar nog steeds werkt.
Als tussendoor onderhoud blokken wordt gedaan (de communiactie moet dan gestopt zijn natuurlijk) lukt het niet de regelaar aan de gang te krijgen via een start communicatie.
Het "probleem" reproduceert goed; ik heb het vaak geprobeerd.
Als je meer wilt testen kan ik dat zondagmiddag doen.

mvg Anton
Ga naar bovenaan de pagina

AntonBuiteweg

Belgium
18 Posts

Geplaatst - 18 jan 2012 :  10:43:59  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Hallo Paul,
Ik heb nu de echte joystick vervangen door de schakeling zoals beschreven in jouw documentatie. Ik heb daarbij het volgende ontdekt:
- Tussen pin 9 en 13 moet een weerstand zitten van 100kohm (staat ook in het schema en zonder deze weerstand krijg ik de foutmelding).
- De potmeters moeten 220kohm zijn, anders rijdt de loc al in de nulstand (wordt meestal wel afgevangen door koploper).
- Als de foutmelding komt werkt het ook niet.
- De regelaars werken alleen na het eerste opstarten van koploper.
Bij daarna stop communicatie en start communicatie werkt het niet meer. (dit is in tegenspraak met mijn vorig bericht, mogelijk heb ik dat in versie 7.2 gezien).
- Bij het configureren van de regelaar is het mogelijk in te geven de melding te "negeren". Dit heeft geen invloed op het niet werken na een herstart van de communicatie; je ziet alleen de foutmelding dan niet meer, maar het werkt niet.
Misschien kun je hier iets mee. Ik kan altijd nog wel iets nieuws proberen voor je.
Nogmaals: voor mij is hier wel mee te leven aangezien ik de handregelaars alleen maar incidenteel wil gebruiken.
Het week-end zal ik nog eens testen of er in versie 7.2. verschillen zijn (met name in de herstart communicatie)

mvg
Anton
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 18 jan 2012 :  11:53:44  Toon profiel  Reageer met citaat
Anton,

Voorzover ik kan zien zal het ook op deze manier werken in 7.2. Er zijn zeker geen wijzigingen geweest op dat gebied, daar ik zelf niet werkt met handregelaars (nog erger: ik heb geen treinbaan meer).

Het schema is ook niet van mijzelf, maar ooit door iemand anders aangeleverd.

Het lijkt er dan op of het stoppen van de joystick niet goed werkt onder Windows Xp. Ga hier niet meer verder naar zoeken.

Mvg,
Paul.

Mvg,
Paul.
Ga naar bovenaan de pagina

AntonBuiteweg

Belgium
18 Posts

Geplaatst - 21 jan 2012 :  12:18:14  Toon profiel  Bezoek de homepagina van AntonBuiteweg  Reageer met citaat
Hallo Paul,
Ik begrijp volkomen, dat je er geen tijd meer in wilt steken. Nog een laatste vraag en dan kunnen we dit lijntje wel sluiten: werkte het wel goed onder windows 95 of windows 98, eventueel windows 7?

Bedankt voor al je reacties.
mvg
Anton
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 21 jan 2012 :  14:48:58  Toon profiel  Reageer met citaat
Anton,

Windows 95/98 heb ik het voor ontwikkeld en daar werkt het zeker (voorzover ik weet). Kan het momenteel niet testen (heb geen baan meer; net gisteren begonnen met nieuwe te bouwen).
Onder Windows 7 verwacht ik nog meer problemen dan Xp.

Mvg,
Paul.
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp Volgend onderwerp  
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina