Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 227 / Bezoekers Vandaag: 2982
Hoogste aantal aktieve gebruikers: 325
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

 Alle forums
 Update's
 Versie 8.2
 Koploper 8.2 bta versie
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp   

Ben

Netherlands
553 berichten

Geplaatst - 08 jul 2013 :  08:27:29  Toon profiel  Reageer met citaat
Wellicht heeft niet iedereen dat op het vizier.

Er is een Koploper 8.2 bta versie beschikbaar op http://www.pahasoft.nl/

Gr, Ben.

Agebe

Netherlands
395 Posts

Geplaatst - 31 jul 2013 :  13:39:40  Toon profiel  Reageer met citaat
Hallo Allemaal,

Geconstateerd in de bta versie van koploper:
Het resetten van de tel functie door middel van een logische actie, werkt niet meer zoals voorheen.
Het resetten gebeurde altijd als de logische actie waar wordt.
Nu als de logische actie waar is, het gevolg is, dat de teller niets meer doet als de LA waar is.
Ik heb dit nu opgelost met een sequens, waar een logische actie echt een kort moment waar wordt.

2 De klok komt na het starten van koploper altijd op in de verborgen toestand, deze moet dus altijd weer aan gezet worden, hetzij in menu algemeen of via het klok icoontje.

Misschien is het wel de bedoeling zo, dan heb ik niets gezegd.

Mvg Ab

(Koploper met ECOS of IB met loconet,HSI-88,3x tams booster B1, HO, NS)
AMD Athlon 7450 dual core met W7
Ga naar bovenaan de pagina

phdirk

Netherlands
1963 Posts

Geplaatst - 31 jul 2013 :  15:53:22  Toon profiel  Reageer met citaat
Hi All,

Voor wat betreft de klok constateerde ik in eerste instantie hetzelfde als Ab in mijn database. Ik heb toen een andere database geselecteerd (dus niet teruggelezen van een bck-file). Deze database had geen klok. Die heb ik toen aangezet en vastgezet. Bij het opnieuw starten van Koploper kwam de klok keurig mee. Nadat ik mijn eigen database weer had opgeroepen bleef ook daar de klok keurig zichtbaar. Hij staat nu bij het opstarten wel door het baanoverzicht heen, maar dat baanoverzicht moet dan nog naar de andere monitor worden verschoven. Omdat die monitor boven de hoofdmonitor hangt, is die positie niet vast te zetten.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

Agebe

Netherlands
395 Posts

Geplaatst - 31 jul 2013 :  18:42:26  Toon profiel  Reageer met citaat
Hallo Allemaal,

Na het installeren van koploper 8.3B3 en een keer draaien n de herstel mode is het probleem met de klok verholpen.
Voor de teller functie is het probleem niet verdwenen.
Maar zoals bovenstaand beschreven is het weer werkzaam gemaakt.

Mvg Ab

(Koploper met ECOS of IB met loconet,HSI-88,3x tams booster B1, HO, NS)
AMD Athlon 7450 dual core met W7
Ga naar bovenaan de pagina

PaHaSOFT

3388 Posts

Geplaatst - 31 jul 2013 :  20:32:01  Toon profiel  Reageer met citaat
Ab,

Test eens met deze database:

Database: TestResetTeller.bck
Hierin kan je dus wel een teller resetten en de logische actie waar laten terwijl je aan optellen bent.

Wat wel anders werkt is dat als de logische actie tbv reset niet waar wordt de teller ook weer wordt gereset. Dit werkt anders (verklaar ik nog niet waarom). Ik ga dit wel tzt repareren.

Mvg,
Paul.
Ga naar bovenaan de pagina

Agebe

Netherlands
395 Posts

Geplaatst - 01 aug 2013 :  13:04:39  Toon profiel  Reageer met citaat
Hallo Paul,

Bedankt voor je reactie, ik heb het voorbeeld uit geprobeerd.
Ook in mijn database, en snap nu ook waarom het niet meer werkt.
Het kortstondig resetten met de sequens werkt naar mijn tevredenheid.

(De optie waarvoor ik deze tellers gebruikte ligt in het verleden. waarbij ik een tekst kon tonen, of niet, met behulp van een teller.
Het doel hiervan is het zichtbaar maken op het scherm waar er sluiting is geweest. Welke booster, c.q. welk baan gedeelte.
Eigenlijk kan dit nu met de logische tekst, en zijn deze tellers niet meer nodig.)

Maar het ging mij nu om de teller, omdat een treinen teller hetzelfde euvel had.
Zelf denk ik dat de laatste regel van jouw bericht iets over de oorzaak verteld.

Mvg Ab

(Koploper met ECOS of IB met loconet,HSI-88,3x tams booster B1, HO, NS)
AMD Athlon 7450 dual core met W7
Ga naar bovenaan de pagina

PaHaSOFT

3388 Posts

Geplaatst - 01 aug 2013 :  13:16:48  Toon profiel  Reageer met citaat
Ab,

Het probleem is gevonden in mijn pauze. Van het weekend zal ik deze patchen op het internet. Bedankt voor het zeer oplettend kijken naar de telfuncties.

Mvg,
Paul.
Ga naar bovenaan de pagina

Agebe

Netherlands
395 Posts

Geplaatst - 01 aug 2013 :  14:53:24  Toon profiel  Reageer met citaat
Hallo Paul,

Bedankt voor je inzet.


Mvg Ab

(Koploper met ECOS of IB met loconet,HSI-88,3x tams booster B1, HO, NS)
AMD Athlon 7450 dual core met W7
Ga naar bovenaan de pagina

PaHaSOFT

3388 Posts

Geplaatst - 03 aug 2013 :  07:32:59  Toon profiel  Reageer met citaat
Ab,

Even de nieuwe betaversie downloaden en de reset van de tellers werken weer zoals je was gewend.

Mvg,
Paul.
Ga naar bovenaan de pagina

gansep

Netherlands
22 Posts

Geplaatst - 17 aug 2013 :  20:14:33  Toon profiel  Bezoek de homepagina van gansep  Reageer met citaat
Beste Paul,
Ik vond bij het maken van allerlei tekstvakken n optie die niet helemaal werkte zoals bedoeld. Zie bijgevoegde schermafdruk.
Wanneer je kiest voor "locomotiefkenmerk" werkt het vinkje "tekst als blok ....." niet. Bij alle anderen wel. (voor zover van toepassing)
Tekstvak met "wachttijd in blok" is trouwens een waardevolle aanwinst.

Download Attachment: Schermafdruk.jpg
525,81 KB

Groet
Erik

Ga naar bovenaan de pagina

Wim Ros

Netherlands
5422 Posts

Geplaatst - 17 aug 2013 :  20:32:18  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Erik,

En wat werkt er dan niet, zie hier geen enkel probleem daarmee.

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

gansep

Netherlands
22 Posts

Geplaatst - 17 aug 2013 :  22:31:02  Toon profiel  Bezoek de homepagina van gansep  Reageer met citaat
Beste Wim,

Het is eigenlijk andersom. Het werkt te goed.
Het bewuste vinkje is volgens de helpfile bedoeld om de tekst op te laten lichten als de trein zich werkelijk in het blok bevind.
Op de schermafdruk bij blok 710 zie je twee tekstvelden. Treinlengte en lokomotiefkenmerk. Bij beiden staat het vinkje "tekst als blok ...enz" aan. En lokomotiefkenmerk licht op als het blok gereserveerd wordt en treinlengte komt pas in beeld als de trein werkelijk in het blok is. (en dat laatste is juist volgens de helpfile). Eigenlijk peanuts allemaal, maar het viel me op.

Groet
Erik
Ga naar bovenaan de pagina

Wim Ros

Netherlands
5422 Posts

Geplaatst - 17 aug 2013 :  23:09:38  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Erik,

zal wel, alleen snap ik het probleem of te wel je uitleg niet, maar misschien dat iemand anders dat wel doet,

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

gansep

Netherlands
22 Posts

Geplaatst - 18 aug 2013 :  10:15:54  Toon profiel  Bezoek de homepagina van gansep  Reageer met citaat
Aan een blok (in mijn geval 710) zijn twee tekstvakken gekoppeld.
De een geeft het locomotiefkenmerk aan en de ander de treinlengte.
Verder zijn deze tekstvakken exact hetzelfde gedefinieerd.
(incl de twee vinkjes iets zeggen over het verschijnen (geel gemarkeerd op schermafdrukken))
Dus je zou verwachten dat beide tekstvakken tijdens het rijden op hetzelfde moment oplichten / aanspringen.
En dat gebeurt niet.

Volgens mij doet "lokomotiefkenmerk" wel wat op grond van de inste
llingen zou moeten gebeuren en "treinlengte" niet.



Download Attachment: Treinlengte.jpg
520,61 KB

Download Attachment: Lokomotiefkenmerk.jpg
519,87 KB
Ga naar bovenaan de pagina

Wim Ros

Netherlands
5422 Posts

Geplaatst - 18 aug 2013 :  11:44:11  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Erik,

Zal wel aan mij liggen, maar dat werkt gewoon.



Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

gansep

Netherlands
22 Posts

Geplaatst - 18 aug 2013 :  12:08:13  Toon profiel  Bezoek de homepagina van gansep  Reageer met citaat
Beste Wim,

Je gaat niet over n nacht ijs.
Maar in de situatie die je hebt gemaakt (met 1 blok, voor zover ik kan zien) zal je het verschil ook niet zo snel ontdekken.
In een situatie met meerdere blokken, waarin de trein zich verplaatst, zal het verschil wel zichtbaar worden. Want die vinkjes (en zeker die laatste) heeft te maken met het verplaatsen van een trein.
Benieuwd naar je bevindingen.

Groet
Erik

Ga naar bovenaan de pagina

Wim Ros

Netherlands
5422 Posts

Geplaatst - 18 aug 2013 :  12:29:39  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Erik zeg het maar. Volgens mij werkt het gewoon, of ik snap je probleemstelling niet, dat kan ook.





Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

gansep

Netherlands
22 Posts

Geplaatst - 18 aug 2013 :  12:50:55  Toon profiel  Bezoek de homepagina van gansep  Reageer met citaat
Volgens mij ben je dichtbij .....
Laat nu die trein eens rijden (met bijv 2 blokken vooruit gereserveerd) van blok 76 -> 10 -> 109 (o.i.d, als ie maar langs 10 komt) En let dan goed op het (moment van) verschijnen van de beide teksten. (bij mij is dat dus niet gelijktijdig, terwijl je dat op basis van de instellingen wel zou verwachten)
Ga naar bovenaan de pagina

Wim Ros

Netherlands
5422 Posts

Geplaatst - 18 aug 2013 :  13:51:35  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
Erik,

De lengte wordt getoond als het blok is gereserveerd door de lok, het kenmerk als de lok daadwerkelijk in het blok is, wat is daar niet goed aan dan?
Anders dan dat je verwacht, maar is jouw verwachting conform de werkelijkheid? Of werkt het toch anders?
Mijn gevoel zegt dat het gewoon werkt, als Paul een andere mening daarover heeft volgt er vanzelf een update.

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

gansep

Netherlands
22 Posts

Geplaatst - 18 aug 2013 :  14:18:14  Toon profiel  Bezoek de homepagina van gansep  Reageer met citaat
Wim,

Kijk, we hebben in ieder geval hetzelfde beeld bij dezelfde situatie.

Nu zal het de gemiddelde gebruiker (ook mij)niet heel veel uitmaken wanneer iets wel of niet verschijnt, ware het niet dat de programmeur bewust twee mogelijkheden heeft gecreerd (de vinkjes) om (het moment van) de zichtbaarheid te benvloeden. En dan is het wel mooi als het ook als zodanig werkt.

Het is eigenlijk meer een programmeur issue dan een gebruikers probleem. En daarmee is de bal wel rond denk ik zo.

Groet
Erik
Ga naar bovenaan de pagina

Wim Ros

Netherlands
5422 Posts

Geplaatst - 08 sep 2013 :  09:50:15  Toon profiel  Bezoek de homepagina van Wim Ros  Reageer met citaat
build 7 is beschikbaar

Mvg
Wim.


Alleen de waarheid ligt in het midden

s88SD16-n s88XPressNetLI LocoNet-Interface s88LN xTreme Keerlus
Ga naar bovenaan de pagina

Ben

Netherlands
553 Posts

Geplaatst - 08 sep 2013 :  11:28:10  Toon profiel  Reageer met citaat
Goed werk Paul en Wim.

Gr, Ben.
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp   
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina