Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 246 / Bezoekers Vandaag: 3104
Hoogste aantal aktieve gebruikers: 276
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

 Alle forums
 Update's
 Versie 8.0
 Foutmelding I/O Error 32 bij verlaten koploper
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Vorige pagina | Volgende pagina
Auteur Vorig onderwerp Onderwerp Volgend onderwerp Pagina: 1 2 3 (of 3)

avanlaar

Netherlands
35 Posts

Geplaatst - 26 feb 2013 :  11:31:41  Toon profiel  Bezoek de homepagina van avanlaar  Reageer met citaat
Hallo Paul en Wim,

Ik ben nog even aan het stoeien geweest.
Als ik 8.1 installeer en dan de database restore,
dan ziet alles er goed uit.

In de database folder zijn dan ook de beide .txt files aan wezig.
save.txt en Save_oud.txt.

Als ik nu verder niets doe, dan kan ik koploper normaal afsluiten.
Maar als ik dan kijk in de datbase folder is wel Save_oud.txt aanwezig, edoch save.txt mist in zijn geheel.

Start ik nu koploper weer op dan heb ik geen loks meer.
en bij het afsluiten krijg ik I/O error 32 en moet ik koploper afsluiten met de task manager.

Ik hoop dat je hier wat aan hebt.

Met vriendelijke groeten,

André van Laar.

Schaal HO, Fleischmann, MRdirect en Koploper.
Windows 7 home premium 64 bits.
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 26 feb 2013 :  12:15:22  Toon profiel  Reageer met citaat
Hallo Paul, Wim en anderen,

Nog wat aanvullingen van mijn kant.

Mijn databases staan al jaren in de map D:/Koploper Databases/Actieve databases, juist in verband met de rechtenkwestie. Koploper zelf staat wel in de C:/Program Files map. Ook bij mij is de lokdatabase na twee keer inladen leeg of grotendeels leeg. Restoren kan gewoon vanuit de backup en dat gaat het weer twee keer goed, daarna is de database weer leeg.
Overigens gaat het met de demodatabase niet fout, dan werkt Koploper 8.1.1. op de Windows 7 (32 bit) laptop prima. Die staat natuurlijk wel op Selectrix. Ik kan nog eens kijken wat er gebeurt als ik die op IB/TC zet. Andersom heb ik dat al wel geprobeerd, namelijk Selectrix kiezen als systeem, maar dan krijg ik nog steeds dezelfde fout.
In de wel werkende versie zie ik nog wel steeds de cursor in het Overzicht Locomotieven staan. Het verminderen van het aantal locomotieven in de database heeft geen effect. Ik heb op een gegeven 2 locs overgehouden, die niet verwijderd konden worden, omdat ze verbonden waren met een logische actie. Ook dan gaat het fout.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

PaHaSOFT

3325 Posts

Geplaatst - 26 feb 2013 :  13:07:03  Toon profiel  Reageer met citaat
Iedereen,

Wat ik ook doe ik kan dit niet naspelen onder Windows 7. Het blijft gewoon goed gaan.

Ik moet allereerst gewoon zien wat er gebeurd, want jullie doen meer dan dat je beschrijft. Als er iemand is met een Pc/laptop die het kan laten zien dat het eerst met versie 8.0 goed gaat en hierna met versie 8.1 dan fout, hou ik mij bevolen. Ik kan dan ook middels tijdelijke versie misschien met extra messages plaatsen zodat we kunnen opsporen waar het fout gaat.

Als iemand vanavond of morgenavond tijd/zin heeft om langs te komen dan hoor ik dat graag, anders wordt het ergens volgende week en die heb ik nog niet in mijn hoofd zitten.

Mvg,
Paul.
Ga naar bovenaan de pagina

bobm

Netherlands
79 Posts

Geplaatst - 26 feb 2013 :  13:11:15  Toon profiel  Reageer met citaat
Beste allen,

Voor wat het waard is:op windows 7 32bits vanmorgen 8.1 build 1 geïnstalleerd gelijk kreeg ik deze melding, nooit eerder gehad.

groetend bob


Download Attachment: melding.JPG
43,03 KB
Ga naar bovenaan de pagina

PaHaSOFT

3325 Posts

Geplaatst - 26 feb 2013 :  13:18:00  Toon profiel  Reageer met citaat
Bob,

Dit is een melding van het installatie programma. Daarvan ben ik ook maar gewoon een gebruiker. Je hebt iets uitgepakt wat daarna bij het runnen niet meer blijkt te bestaan. Dat is iets totaal buiten Koploper.

Mvg,
Paul.
Ga naar bovenaan de pagina

HeRo

18 Posts

Geplaatst - 26 feb 2013 :  13:45:39  Toon profiel  Reageer met citaat
quote:
Oorspronkelijk geplaatst door PaHaSOFT

Wim/Robin,

@Robin
Bedankt voor het proberen, maar het heeft helaas weinig helderheid verschaft. Hoe hebt jij het gedaan? Heb jij in Koploper een andere basis directory aangemaakt en in Koploper bekend gemaakt en toen een backup teruggelezen?

Mvg,
Paul.



Paul,

Ik heb een nieuwe database aangemaakt met dezelfde naam als de back up.
Dit is na het verplaatsen van de map gedaan.
Toen een back up in die map geplaatst en vanaf daar ingeladen.(wel als back up zijnde)

Maar als ik een nieuwe database aanmaak heb ik de zelfde problemen.
Laatste poging strandde na het plaatsen van 2 wissels en een treinstel.
Na die opgeslagen te hebben wilde ik de communicatie opstarten om het licht van een treinstel aan te doen.
Op dat moment kwam de fout melding.

Wat ook voorkomt is dat het tot 30 seconden duurt voordat het rode spiegelei van groen naar rood over springt.Met een enorm cpu verbruik op dat moment.

Mvg,Robin
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 26 feb 2013 :  14:40:36  Toon profiel  Reageer met citaat
Hallo Paul, Wim en anderen,

Ik heb net even een hele nieuwe database aangemaakt op de Windows 7 (32 bits) laptop. Dat werkt prima.

Ik kom overigens graag vanavond of morgenavond langs met de bewuste PC. Laat maar even weten wat je het beste past per DM.

Nog even in zijn algemeenheid:

Bij versie 8.0.6 geen problemen.

Bij Versie 8.1.1 na inladen backup: normaal beeld.

Bij tweede maal inladen: normaal beeld.

Bij derde maal inladen: leeg overzicht locs.

Zie ook bijgevoegde pdf



Download Attachment: KPLprobleem.pdf
549,86 KB

Met beste groeten
Dirk
HO=TC

Bewerkt door phdirk op 26 feb 2013 14:44:24
Ga naar bovenaan de pagina

PaHaSOFT

3325 Posts

Geplaatst - 26 feb 2013 :  14:55:06  Toon profiel  Reageer met citaat
Dirk,

Je hebt een pbtje voor morgenavond (met gegevens).

Voor mij is het echt noodzakelijk het verschil tussen 8.0 en 8.1 te kunnen zien/simuleren en hopelijk te verhelpen (al kan ik in deze geen garantie geven).

Mvg,
Paul.
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 26 feb 2013 :  15:21:14  Toon profiel  Reageer met citaat
Hallo Paul,

Als het goed is heb je mijn antwoord ontvangen. Op de betreffende laptop staan beide versies (8.0.6 en 8.1.1) en eventueel ook nog 7.5.21.
Ik heb nog even geprobeerd de backup als nieuwe database in te laden, maar dat geeft dezelfde problemen.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

PaHaSOFT

3325 Posts

Geplaatst - 27 feb 2013 :  22:23:55  Toon profiel  Reageer met citaat
Heren (en misschien Dames),

Met dank aan Dirk om langs te komen met een probleem geval, is het toch mogelijk geweest om de fout op te sporen en op te lossen.

Met Koploper 8.1 buildnummer 2 is deze fout verholpen. Ik hoop dat alles nu wel werkt bij jullie.

Mvg,
Paul.
Ga naar bovenaan de pagina

HeRo

18 Posts

Geplaatst - 27 feb 2013 :  23:16:35  Toon profiel  Reageer met citaat
Hallo Paul,

Dank voor de oplossing.Hier kunnen mutaties weer succesvol worden weggeschreven.

Groeten Robin
Ga naar bovenaan de pagina

avanlaar

Netherlands
35 Posts

Geplaatst - 28 feb 2013 :  10:19:34  Toon profiel  Bezoek de homepagina van avanlaar  Reageer met citaat
Goede morgen Paul,

Ik ben blij dat het toch opgelost is, ga het van avond ook uitproberen.
Ik zit nu op mijn werk.
Ook Dirk bedankt, dat je de moeite heb genomen om bij Paul langs te gaan.
Klasse

Met vriendelijke groeten,

André van Laar.

Schaal HO, Fleischmann, MRdirect en Koploper.
Windows 7 home premium 64 bits.
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 28 feb 2013 :  15:10:12  Toon profiel  Reageer met citaat
Hallo André, Robin en andere Koplopergebruikers,

Bedankt voor de dankbetuigingen, het is graag gedaan, maar bedank vooral Paul dat hij een avond heeft besteed om dit probleem te tackelen. Het blijkt dat, ondanks dat de PC op Nederlandse notatie staat en dus komma's gebruikt als decimaalteken, hij toch bestanden wegschrijft met een punt als decimaalteken. Het zal jullie niet verbazen dat dat problemen geeft.

Met beste groeten
Dirk
HO=TC

OEF, Toch misschien te vroeg gejuicht.
Bij het installeren van versie 8.1B2 op mijn laptop kreeg ik een Floating Point error, die nu trouwens ook optrad bij de testversie van gisteravond. Door in het Configuratiescherm bij "Land en Taal" het decimaalteken te veranderen naar een punt in plaats van een komma, kan Koploper wel worden opgestart en wordt de database netjes ingeladen. Daarna kan het decimaalteken weer worden teruggezet naar een komma en blijft het bij de betreffende database ook goed gaan. Bij een nieuwe database die wordt ingeladen via [Algemeen]=>[Selecteren Database] kan het weer fout gaan en moet bovenstaande procedure worden gevolgd om het weer goed te krijgen.
Als de database wordt aangemaakt vanuit het backupbestand lijkt het wel goed te gaan.
Als Paul hierover meer wil weten, kan hij natuurlijk contact met me opnemen.




Bewerkt door phdirk op 28 feb 2013 16:19:17
Ga naar bovenaan de pagina

bellejt

Belgium
453 Posts

Geplaatst - 28 feb 2013 :  16:23:00  Toon profiel  Reageer met citaat
mss nog een vraagje hierop : dit heeft toch rechtstreeks te maken met je landinstellingen ? Als je nederland/nederlands of nederland/belgisch kiest heb je dat verschil van de komma of punt.


greetings,groetjes,salutations,Johnny T
Koploper-ECOS2 + 3 boosters ESU 8 Amp - PC P4 - decoders Viessman
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 28 feb 2013 :  16:36:28  Toon profiel  Reageer met citaat
Hallo Johnny,

Dat is nu het mysterie van meneer Gates. Hoewel al mijn PC's netjes op Nederland - US Internationaal Keyboard staan en dus aangeven de komma als decimaalteken te gebruiken en dat ook doen - dat kun je makkelijk controleren in EXCEL -, wordt bij het wegschrijven van een bepaald bestand kennelijk toch een punt als decimaalteken gebruikt bij één van de PC's (bij de andere gaat het allemaal vlekkeloos). Door nu wat te spelen met het instellen van het decimaalteken op een punt en dan weer op een komma, is het allemaal weer in het gareel te krijgen. Wie het nog begrijpt mag het zeggen.


Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

avanlaar

Netherlands
35 Posts

Geplaatst - 28 feb 2013 :  17:55:34  Toon profiel  Bezoek de homepagina van avanlaar  Reageer met citaat
Hallo Paul en Dirk,

Eindelijk weer thuis.
Meteen geinstalleerd en getest.

Ook bij mij werkt het tot nu toe vlekkeloos.
Ik heb hier ook alle vertrouwen in.

Paul en Dirk, nogmaals bedankt voor alle moeitje en tijd die jullie hier in hebben gestoken.
Koploper is en blijft een perfect en het beste programma.



Met vriendelijke groeten,

André van Laar.

Schaal HO, Fleischmann, MRdirect en Koploper.
Windows 7 home premium 64 bits.
Ga naar bovenaan de pagina

PaHaSOFT

3325 Posts

Geplaatst - 28 feb 2013 :  19:54:51  Toon profiel  Reageer met citaat
Andre,

Blij om te lezen dat het bij jouw ook is opgelost. Jij was de 'aanstichter' van dit alles en het zou wel jammer zijn geweest als het bij jouw niet wat opgelost.

Mvg,
Paul.
Ga naar bovenaan de pagina

Agebe

Netherlands
381 Posts

Geplaatst - 28 feb 2013 :  20:10:31  Toon profiel  Reageer met citaat
Hallo Dirk,

quote:
Dat is nu het mysterie van meneer Gates. Hoewel al mijn PC's netjes op Nederland - US Internationaal Keyboard staan en dus aangeven de komma als decimaalteken te gebruiken en dat ook doen - dat kun je makkelijk controleren in EXCEL -, wordt bij het wegschrijven van een bepaald bestand kennelijk toch een punt als decimaalteken gebruikt bij één van de PC's (bij de andere gaat het allemaal vlekkeloos). Door nu wat te spelen met het instellen van het decimaalteken op een punt en dan weer op een komma, is het allemaal weer in het gareel te krijgen. Wie het nog begrijpt mag het zeggen.


Het heeft te maken waar de maker van de PC de voor geïnstalleerde of zelfs met CD vandaan heeft. Je kunt immers voor verschillende talen kiezen. Soms blijft er in een interne software laag iets van de oorspronkelijke taal hangen. (En ja het is gewoon legale software)
Door nu bewust te kiezen voor een andere toetsenbord taal en valuta e.d. de computer te resetten, daarna alles weer op Nederland (US keyboard datum tijd enz) te zetten, en weer opnieuw opstarten, verhelpt het probleem.
Mvg Ab

(Koploper,ECOS-IB,HSI-88,3x tams booster B1, HO, NS)
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 01 mrt 2013 :  11:00:46  Toon profiel  Reageer met citaat
Hallo Ab,

Bedankt voor de informatie. Ik zal de procedure eens doorlopen. Het is inderdaad zo dat op deze PC Windows 7 Starter Nederlands voorgeïnstalleerd was en dat ik dat heb geüpgrade naar Home Edition (NL).



Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

bellejt

Belgium
453 Posts

Geplaatst - 01 mrt 2013 :  11:29:30  Toon profiel  Reageer met citaat
Prima,thx voor de info.Weten we in de toekomst als het voorvalt wat gedaan.Bedankt allen en zeker ook Paul voor de inspanningen om ons toch een perfekt werkende versie te bieden.

greetings,groetjes,salutations,Johnny T
Koploper-ECOS2 + 3 boosters ESU 8 Amp - PC P4 - decoders Viessman
Ga naar bovenaan de pagina

phdirk

Netherlands
1882 Posts

Geplaatst - 01 mrt 2013 :  16:15:13  Toon profiel  Reageer met citaat
Hallo Ab en anderen,

Ik heb jouw procedure afgelopen. Het is daarbij overigens wel vreemd dat het decimaalteken niet veranderd als je naar Engelse instellingen schakelt, dus dat heb ik handmatig meegenomen.
Het probleem lijkt nu te zijn verholpen. Ik heb bij het inladen van databases nog geen fouten gemerkt.

Toch te vroeg gejuicht:
Net nog even geprobeerd. Koploper stond nog aan met mijn database open. Even een andere ingeladen via [Selecteer Databsse]. Dat ging goed. Daarna mijn database weer willen laden via [Selecteer Database]. Gevolg: een eindeloze serie Floating Point errors. Even weer de punt ingesteld als decimaalteken. Database is weer keurig in te laden, met natuurlijk de melding dat de vorige keer Koploper niet netjes is afgesloten, ook de treinstanden zijn goed.
Daarna weer naar de komma als decimaalteken. Andere database inlezen gaat goed en daarna kan ook de eigen database zonder problemen worden ingelezen.
Voor Paul: er staan nu ook keurig komma's in de tweede serie kmstanden in de save-oud-file.



Met beste groeten
Dirk
HO=TC

Bewerkt door phdirk op 01 mrt 2013 16:29:45
Ga naar bovenaan de pagina

HeRo

18 Posts

Geplaatst - 02 mrt 2013 :  19:25:27  Toon profiel  Reageer met citaat
Dirk,
Hier loopt de boel nu ook opeens weer vast.
Krijg een floating point overflow.
Waar stel je die . ipv , in.
Ik heb een NL versie van Windows 7 maar kan niets anders als een , kiezen bij decimaal notitie bij de regio settings

Mvg,Robin
Ga naar bovenaan de pagina

bobm

Netherlands
79 Posts

Geplaatst - 02 mrt 2013 :  20:11:42  Toon profiel  Reageer met citaat
Beste Robin,

als je notatie Nederlands is, moet het goed zijn.
configuratiescherm>klok,taal,regio>land en taal>notaties>nederlands
voorbeeld 100.000,00 euro is in VS 100,000.00 euro

groetend, bob
Ga naar bovenaan de pagina

HeRo

18 Posts

Geplaatst - 02 mrt 2013 :  20:28:13  Toon profiel  Reageer met citaat
Bob,

Zou het goed moeten zijn.Dat is het dus niet.
Daar is Windows nu ook achter en er is een rapport naar microsoft verstuurd.
Ik zag dat mij computer zichzelf vannacht wat updates heeft gevoed dus daar zal het probleem wel uit voort zijn gekomen.

De file draait op een andere machine in de test probleemloos.
Dat is alleen een Windows 8 machine en daar draait mijn usb serial convertor niet op.

Mvg Robin
Ga naar bovenaan de pagina

bobm

Netherlands
79 Posts

Geplaatst - 02 mrt 2013 :  20:36:45  Toon profiel  Reageer met citaat
Hallo Robin,

als ik die genoemde notatie verander in engels{ VS]
krijg ik een opeenvolging van floating point overflows.
Je hebt toch ook weer je veranderde decimaalsettings teruggezet?,

groetend, bob


Ga naar bovenaan de pagina
Pagina: 1 2 3 (of 3) Vorig onderwerp Onderwerp Volgend onderwerp  
Vorige pagina | Volgende pagina
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina