Koploperforum Digitale Treinbesturing Aktieve Gebruikers: 215 / Bezoekers Vandaag: 1876
Hoogste aantal aktieve gebruikers: 397
Google


Koploperforum Digitale Treinbesturing
Startpagina | Mijn bestanden | Profiel | Registreer | Recente onderwerpen | Leden | Zoeken | FAQ
Gebruikersnaam:
Wachtwoord:
Selecteer taal
Wachtwoord opslaan
Wachtwoord vergeten?

Modelspoorwijzer.net

 Alle forums
 Installatie
 Technische installatie
 CPU gebruik
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Auteur Vorig onderwerp Onderwerp Volgend onderwerp  

Modeltram

Netherlands
24 berichten

Geplaatst - 27 jan 2010 :  11:44:18  Toon profiel  Bezoek de homepagina van Modeltram  Reageer met citaat
Beste koplopergebruikers,

Voor mijn baan heb ik een nieuwe computer in gebruik genomen, die volledig stand-alone koploper draait. Hij is voorzien van een verse installatie van XP en alle overbodige onderdelen zijn verwijderd, zodat niets koploper in de weg kan zitten. Nu viel het mij op dat tijdens het draaien van Koploper het cpu gebruik tussen de 80% en de 90% zit. Dit gebeurd zelfs al als alles stil staat in het schaduwstation wanneer je het automatisch rijden activeert

De computer is een Pentium 3 op 1 Ghz met 384 mb ramm geheugen. Nu had ik altijd het idee dat koploper juist perfect zou draaien op de oudere pcs maar het aantal cyclis zit nu al 230 (met de tuningoptie aan).

Na wat experimenteren zag ik dat het cpu gebruik stijgt naar mate je meer materieel op je baan zet. De 80% wordt bereikt met 35 trams. Nu heb ik het op meerdere pc getest, maar de resultaten lieten toch hetzelfde zien: P3 1400mhz op 75%, P4 1,7 op 70% en pas op de huidige generatie dual cores kreeg ik 30%. Nu had ik op mijn laatste tentoonstelling de dual core draaien op Vista met een usb converter en dat was een ramp icm Koploper. Mijn oude P3 zou de oplossing moeten zijn, maar is het hoge cpu gebruik normaal voor een baan met actieve 35 loks? (er rijden er maar maximaal 9 tegelijk)

Groeten,
Mark van Dijk


Modeltrams in 1:87 en Marklin Spoor 1

buckfast_beekeeper

Belgium
78 Posts

Geplaatst - 27 jan 2010 :  17:16:25  Toon profiel  Reageer met citaat
Hier met Vista Home Premium en een Centrino Duo T7700 2.4GHz geen problemen met een USB=>RS232 converter.

Het is zeer dikwijls wel wat zoeken naar de goede combinatie driver/OS/converter.





MVG

Theo

Honing kan men importeren, bestuiving niet
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 27 jan 2010 :  19:36:14  Toon profiel  Reageer met citaat
Mark,

Wat is nu precies je probleem? Ik lees alleen maar dat jij je verontrust, maar gaat er daadwerkelijk iets fout?

Mvg,
Paul.
Ga naar bovenaan de pagina

Modeltram

Netherlands
24 Posts

Geplaatst - 27 jan 2010 :  22:41:20  Toon profiel  Bezoek de homepagina van Modeltram  Reageer met citaat
Beste Paul,

Ik ondervind er geen problemen mee, maar ik vroeg mij af of dit normaal was. Koploper draait vaak op oude computers en ik vond het cpu gebruik behoorlijk hoog voor mijn P3. Ik ben van plan om mijn schaduwstation nog verder uit te breiden, waardoor er nog veel meer trams bijkomen binnen koploper (+/- 30 stuks) en ik hoop niet dat mijn computer dan de beperkende factor wordt.

Groeten, Mark

Modeltrams in 1:87 en Marklin Spoor 1
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 28 jan 2010 :  06:57:07  Toon profiel  Reageer met citaat
Marc,

Ik zou niet inzien waarom het een probleem zou worden en als dat het wel wordt moeten we kijken hoe dit op te lossen is.

Mvg,
Paul.
Ga naar bovenaan de pagina

phdirk

Netherlands
1940 Posts

Geplaatst - 28 jan 2010 :  16:37:58  Toon profiel  Reageer met citaat
Hallo Mark,

Het lijkt me sterk dat het aan Koploper ligt. Ik heb nog ergens een oude Compaq laptop (0de generatie), waar nog W98 op zit(als ik het goed heb iets van 600MHz en 16MB intern). Koploper draait erop als de bekende trein. Van XP is wel bekend dat het nogal een aanslag pleegt op je systeem. De opvolger van de bovengenoemde laptop draaide ook op XP en was behoorlijk vol bezet. Op een gegeven moment heb ik hem "teruggetuned" naar W98 en dat hielp behoorlijk. Het is veel werk, maar je zou dat experiment ook kunnen uitvoeren.

Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 28 jan 2010 :  16:41:29  Toon profiel  Reageer met citaat
Dirk,

Juist zou onder een NT versie van Windows (en Window XP valt daar ook onder) de CPU veel minder werken dan onder W98.

Wat zeker meespeelt: hoeveel treinen (eh trams) willen eigenlijk verder rijden maar moeten steeds controleren of een volgend blok vrij is. Als dit meer wordt (en deze rijden dus niet eens) is het voor Koploper zwaarder.
Het ligt dus ook zeker aan de baan/schaduwstation hoe Koploper functioneert.

Mvg,
Paul.
Ga naar bovenaan de pagina

phdirk

Netherlands
1940 Posts

Geplaatst - 28 jan 2010 :  17:07:16  Toon profiel  Reageer met citaat
Hallo Paul,

Bedankt vor deze toelichting. Dat maakt, in ieder geval voor mij, weer veel duidelijk.

Met beste groeten
Dirk
HO=TC
Ga naar bovenaan de pagina

Modeltram

Netherlands
24 Posts

Geplaatst - 28 jan 2010 :  22:52:18  Toon profiel  Bezoek de homepagina van Modeltram  Reageer met citaat
Hallo Paul en Dirk,

Ik heb mijn oudste computer uit het stof gehaald (P1 200mhz, 32 mb) en daar mijn trambaan op laten draaien. Het resultaat is een cpu gebruik van 100% en een gemiddeld aantal cycli's van 37 (met tuningoptie aan.

Met deze pc kan je niet rijden, want hij mist constant bezetmelders en een hoop commando's lijken niet aan te komen bij de trams en de wissels. Pas nadat ik alle trams op 10 na heb verwijderd ging het weer goed. Mijn schaduwstation is kennelijk teveel gevraagd voor de oude pc.

Ik ben in ieder geval gerust gesteld, dat het niet aan de pc's zelf ligt, maar aan mijn baanontwerp.

Groeten, Mark

Download Attachment: Beurs.bck
90,78KB


Modeltrams in 1:87 en Marklin Spoor 1

Bewerkt door Modeltram op 28 jan 2010 22:52:51
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 29 jan 2010 :  07:03:34  Toon profiel  Reageer met citaat
Marc,

Inderdaad; wat ik al dacht. Heel veel locs/trams staan in een blok en willen eigenlijk rijden, maar kunnen niet rijden omdat het volgende blok bezet is. Dit kost toch "veel" tijd.

Zal er wel eens over nadenken; misschien dat ik er iets slims voor kan verzinnen.

Mvg,
Paul.
Ga naar bovenaan de pagina

sjongele

36 Posts

Geplaatst - 29 jan 2010 :  14:12:08  Toon profiel  Reageer met citaat
Hoi Paul,

Misschien een wild idee, maar dat kun jij beter inschatten

Zou het in dit voorbeeld helpen om voor een de paralel liggende secties (dus bijv. 20,31,42,52, 63) telkens een blokgroep aan te maken en deze op FIFO te zetten?

Als je dat bijvoorbeeld doet voor de groepjes ter hoogte van 18 t/m die bij 25, dan heb je 8 blokgroepen. Jij kunt vast aangeven of je op deze wijze het maximaal aantal te evalueren bewegingen van 8 secties * 5 blokken = 40 reduceert tot 8 (8 x een evaluatie voor de eerste per blokgroep).

Door de wachttijden op de in- en uitrijblokken (ter hoogte van 17 en 26) een grote varatie te geven, zou je in dit geval het gedrag naar buiten niet volledig voorspelbaar maken.

Groeten,

Sander
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 29 jan 2010 :  14:37:18  Toon profiel  Reageer met citaat
Sander,

Volgens mij inderdaad een 'wild' idee.

Je wilt juist dat er in het schaduw station altijd meteen wordt gereden naar een volgend blok indien deze vrij is. Als je hier wat gaat doen met FIFO of LIFO in combinatie met blokgroepen zullen er volgens mij zeer grote gaten vallen.

Ik heb zelf al een idee hoe ik dit kan verbeteren, moet het alleen nog inbouwen en dan draait het waarschijnlijk weer prima op een 'oud' beestje.

Mvg,
Paul.
Ga naar bovenaan de pagina

Modeltram

Netherlands
24 Posts

Geplaatst - 29 jan 2010 :  21:17:13  Toon profiel  Bezoek de homepagina van Modeltram  Reageer met citaat
Paul,

Bedankt dat je een keer hier wil naar kijken en dat mijn oude beestje toch nog een 2e leven kan krijgen.

Groeten, Mark

Modeltrams in 1:87 en Marklin Spoor 1
Ga naar bovenaan de pagina

PaHaSOFT

3361 Posts

Geplaatst - 30 jan 2010 :  22:48:30  Toon profiel  Reageer met citaat
Hallo Mark,

Ben even een het experimenteren geweest. Bijgaand een schermafdruk van CPU statistiek.

Volgens mij duidelijk te zien wanneer ik de optie cycli tuning had aanstaan. Wil er nog wel iets aan verfijnen, maar dat zal bijna niet ten koste gaan de CPU gebruik.

Mvg,
Paul.
Ga naar bovenaan de pagina

Modeltram

Netherlands
24 Posts

Geplaatst - 01 feb 2010 :  10:11:28  Toon profiel  Bezoek de homepagina van Modeltram  Reageer met citaat
Hallo Paul,

Je screenshot ziet er veel belovend uit! Toen in de tuningoptie probeerde zag ik geen grote verschillen, maar zo te zien kan het in jou aangepaste versie een grote rol spelen.

Ik ben benieuwd!

Groeten, Mark

Modeltrams in 1:87 en Marklin Spoor 1
Ga naar bovenaan de pagina

cybertinus

5 Posts

Geplaatst - 27 feb 2010 :  00:46:14  Toon profiel  Reageer met citaat
Hallo,

Ik zit zelf met een vergelijkbaar probleem. Op de MSV waar ik lid van ben hebben we een behoorlijk forse baan. De bedoeling is dat er ongeveer 30 treinen op komen te staan. Rond de 12 daarvan zijn in beweging. De rest staat dus stil. We hebben 56 blokken. We gaan rijden met Dinamo. Dit willen we gaan aansturen met een P1 133 Mhz met Windows 98. Ik zie dat nog niet echt gebeuren, eigenlijk.
Een van de clubleden heeft een testbaantje thuis. Dat is uiteraard een kleiner ding. Daar zitten 8 blokken op met 2 a 3 treinen die kunnen rijden, er kunnen max. 5 treinen op staan. Als ik hierop naar de Systeem Informatie kijk, zit het gemiddeld aantal cycli net boven de 100 (102 ongeveer). Als ik dan logisch nadenk verwacht ik eigenlijk niet dat die P1 133 Mhz met Windows 98 de grote baan kan aansturen. Of zit ik nu heel fout?. En met die testbaan zitten we al heel erg dicht bij het minimum van 100 (staat in de manual van Koploper 6.7 op pagina 213).
Mocht de laptop het toch niet trekken, wat zijn dan de symptomen waaraan ik dat herken? Er worden bezetmeldingen genegeerd las ik al? Of zijn er nog meer dingen. Uiteraard kan ik het ook zien aan het CPU gebruiken memory gebruik, maar hoe veranderd het gedrag van de treinen?
Helaas kan ik het nog niet gewoon uittesten, want de baan is nog niet volledig omgebouwd en initieel getest met Koploper, maar we gaan binnenkort wel naar Rail met die baan, dus ik wil het wel kunnen herkennen daar. Voor de veiligheid neem ik mijn laptop met C2D erin ook maar mee ;).

Wat doen de optie's "Minder resource gebruik" en "Automatische cycli tuning" eigenlijk precies? Ja, het maakt het lichter voor de computer die Koploper draait (met enkele nadelen). Maar hoe doet het dat? Wat veranderd het aan het OS?


ps: is het goed dat ik deze vraag ook in dit topic stel of had ik beter een nieuw topic aan kunnen maken?

Windows 98/Windows XP/Windows Vista, Koploper 6.6, Dinamo, Fleischman N
Ga naar bovenaan de pagina
  Vorig onderwerp Onderwerp Volgend onderwerp  
 Nieuw onderwerp  Reageer op onderwerp
 Printversie
Ga naar:
Koploperforum Digitale Treinbesturing Problemen bij het forum? Stuur een email. Conrad
Bestel hier en steun het forum!
© EKweb 2006
Ga naar begin van deze pagina